当前位置 : 主页 > 手机开发 > 其它 >

Hybrid Crystals

来源:互联网 收集:自由互联 发布时间:2021-06-12
Hybrid Crystals Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 373Accepted Submission(s): 231 Problem Description Kyber crystals, also called the living crystal or simply the kyber, and

Hybrid Crystals

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 373    Accepted Submission(s): 231


Problem Description > Kyber crystals, also called the living crystal or simply the kyber, and known as kaiburr crystals in ancient times, were rare, Force-attuned crystals that grew in nature and were found on scattered planets across the galaxy. They were used by the Jedi and the Sith in the construction of their lightsabers. As part of Jedi training, younglings were sent to the Crystal Caves of the ice planet of Ilum to mine crystals in order to construct their own lightsabers. The crystal's mix of unique lustre was called "the water of the kyber" by the Jedi. There were also larger, rarer crystals of great power and that, according to legends, were used at the heart of ancient superweapons by the Sith.
>
> — Wookieepedia

Powerful, the Kyber crystals are. Even more powerful, the Kyber crystals get combined together. Powered by the Kyber crystals, the main weapon of the Death Star is, having the firepower of thousands of Star Destroyers.

Combining Kyber crystals is not an easy task. The combination should have a specific level of energy to be stablized. Your task is to develop a Droid program to combine Kyber crystals.

Each crystal has its level of energy ( i -th crystal has an energy level of  ai ). Each crystal is attuned to a particular side of the force, either the Light or the Dark. Light crystals emit positive energies, while dark crystals emit negative energies. In particular,

* For a light-side crystal of energy level  ai , it emits  +ai  units of energy.
* For a dark-side crystal of energy level  ai , it emits  ai  units of energy.

Surprisingly, there are rare neutral crystals that can be tuned to either dark or light side. Once used, it emits either  +ai  or  ai  units of energy, depending on which side it has been tuned to.

Given  n  crystals' energy levels  ai  and types  bi  ( 1in ),  bi=N  means the  i -th crystal is a neutral one,  bi=L  means a Light one, and  bi=D  means a Dark one. The Jedi Council asked you to choose some crystals to form a larger hybrid crystal. To make sure it is stable, the final energy level (the sum of the energy emission of all chosen crystals) of the hybrid crystal must be exactly  k .

Considering the NP-Hardness of this problem, the Jedi Council puts some additional constraints to the array such that the problem is greatly simplified.

First, the Council puts a special crystal of  a1=1,b1=N .

Second, the Council has arranged the other  n1  crystals in a way that
aij=1i1aj[bj=N]+j=1i1aj[bi=Lbj=L]+j=1i1aj[bi=Dbj=D](2in).
[cond]  evaluates to  1  if  cond  holds, otherwise it evaluates to  0 .

For those who do not have the patience to read the problem statements, the problem asks you to find whether there exists a set  S{1,2,,n}  and values  si  for all  iS  such that

iSaisi=k,

where  si=1  if the  i -th crystal is a Light one,  si=1  if the  i -th crystal is a Dark one, and  si{1,1}  if the  i -th crystal is a neutral one.  
Input The first line of the input contains an integer  T , denoting the number of test cases.

For each test case, the first line contains two integers  n  ( 1n103 ) and  k  ( |k|106 ). 

The next line contains  n  integer  a1,a2,...,an  ( 0ai103 ).

The next line contains  n  character  b1,b2,...,bn  ( bi{L,D,N} ).  
Output If there exists such a subset, output "yes", otherwise output "no".  
Sample Input
  
  
   
   2

5 9 
1 1 2 3 4
N N N N N 

6 -10
1 0 1 2 3 1
N L L L L D
  
  
 
Sample Output
  
  
   
   yes
no
  
  
  
  
   
   数据小可以过的代码:
  
  
  
  
   
   
#include<stdio.h>
#include<string.h>
#include<bitset>
#include<iostream>
using namespace std;
int L[2000];
//int cun[3000];
char R[2000][3];
bitset<2000050>a,b,tmp;
int abss(int x)
{
    if(x<0)
        return -x;
    return x;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)scanf("%d",&L[i]);
        getchar();
        int sum=0,summ=0;
        for(int i=1; i<=n; i++)
        {

            scanf("%s",R[i]);

            if(R[i][0]=='N'||R[i][0]=='L')
                sum+=L[i];
            if(R[i][0]=='N'||R[i][0]=='D')
                summ+=-L[i];
        }
        if(sum<m||summ>m)
        {
            printf("no\n");
            continue;
        }
        m+=1000000;
        a.reset();
        b.reset();
        int flag=0,k=0;
        for(int i=1; i<=n; i++)
        {
//            b.reset();
            if(R[i][0]=='N')
            {
                tmp=a<<(L[i]);
                tmp[L[i]+1000000]=1;
                b=(b|(tmp));
                tmp=a>>(L[i]);
                tmp[-L[i]+1000000]=1;
                b=(b|(tmp));
                k+=2;
            }
            else if(R[i][0]=='L')
            {
                tmp=a<<(L[i]);
                tmp[L[i]+1000000]=1;
                b=(b|(tmp));
                k++;
            }
            else
            {
                tmp=a>>(L[i]);
                tmp[-L[i]+1000000]=1;
                b=(b|(tmp));
                k++;
            }
            a=b;
            if(b.test(m))
            {
                flag=1;
                break;
            }
        }
        if(flag)
            printf("yes\n");
        else
            printf("no\n");
    }
}
网友评论