当前位置 : 主页 > 编程语言 > java >

C - Maya Calendar

来源:互联网 收集:自由互联 发布时间:2023-09-06
C -Maya Calendar Time Limit:1000MSMemory Limit:10000KB64bit IO Format:%I64d %I64u SubmitStatus Description During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message,


C - Maya Calendar


Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u


Submit Status


Description



During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor. 

For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles. 

Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows: 

1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . . 

Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was: 

Haab: 0. pop 0 

Tzolkin: 1 imix 0 
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar. 



Input



The date in Haab is given in the following format: 
NumberOfTheDay. Month Year 

The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000. 



Output



The date in Tzolkin should be in the following format: 
Number NameOfTheDay Year 

The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates. 



Sample Input



3
10. zac 0
0. pop 0
10. zac 1995



Sample Output



3
3 chuen 0
1 imix 0
9 cimi 2801
注意:当天数能整除260时 year=day/260-1;天的数字号为13,天的单词表示是第二十个单词。
例如:输入:4. uayet 259 输出:13 ahu 364
代码:



#include <iostream>
using namespace std;
int main()
{
    int n,day,year;
    string month1[20]={"","pop","no","zip","zotz","tzec","xul","yoxkin","mol","chen","yax","zac","ceh","mac","kankin","muan","pax","koyab","cumhu","uayet"};
    string month2[21]={"ahau","imix","ik","akbal","kan","chicchan","cimi","manik","lamat","muluk","ok","chuen","eb","ben","ix","mem","cib","caban","eznab","canac"};
    cin>>n;
    string month;
    int m;
    char c;
    cout<<n<<endl;
    for(int i=0;i<n;i++)
    {
        cin>>day>>c>>month>>year;
        year=365*year;
        int i1;
        for(i1=0;;i1++)
        {
            if(month==month1[i1])
                break;
        }
        m=i1-1;


        m=m*20+year+day+1;
        int year2=m/260;
        m=m%260;
        if(m==0)
        {
            year2--;
        }


        int m1=m%20;
        int day1;
        day1=m%13;
        if(day1==0)
            day1=13;
        cout<<day1<<' '<<month2[m1]<<' '<<year2<<endl;
    }
    return 0;




}



上一篇:BIO、NIO和AIO
下一篇:没有了
网友评论