当前位置 : 主页 > 网络编程 > PHP >

hdu1671 Phone List (字典树)

来源:互联网 收集:自由互联 发布时间:2023-10-08
Phone List Time Limit: 3000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 15853Accepted Submission(s): 5326 Problem Description Given a list of phone numbers, determine if it is consistent in the sense


Phone List



Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15853    Accepted Submission(s): 5326



Problem Description


Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.


 



Output


For each test case, output “YES” if the list is consistent, or “NO” otherwise.



Sample Input


2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

 



Sample Output


NO YES


 



Source


​​2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(3)​​



Recommend


lcy   |   We have carefully selected several similar problems for you:   ​​1075​​​  ​​​1247​​​  ​​​1800​​​  ​​​1677​​​  ​​​1298​​ 




代码:

#include<cstdio>
#include<cstring>
#define ms(a,x) memset(a,0,sizeof(a[0])*(x+5))
using namespace std;

const int maxn=1e4;
const int max_len=10;
int num,f[maxn*max_len][10];
bool v[maxn*max_len];

int main()
{
//freopen("1.in","r",stdin);

int i,j,t,n,len;bool flag;char s[max_len+5];
for(scanf("%d",&t);t;t--)
{
ms(f,num),ms(v,num),flag=num=0;
for(scanf("%d",&n);n && scanf("%s",s);n--)
{
if(flag)continue;
len=strlen(s);
for(i=0,j=0;!v[i] && j<len;i=f[i][s[j++]-'0'])
if(f[i][s[j]-'0']==0)f[i][s[j]-'0']=++num;
if(flag=v[i]++)continue;
for(j=0;j<10;j++)if(f[i][j]){flag=1;break;}
}
printf("%s\n",flag?"NO":"YES");
}
return 0;
}



上一篇:基于 Swoole 搭建 WebSocket 服务详解
下一篇:没有了
网友评论