当前位置 : 主页 > 手机开发 > ROM >

PAT Advanced 1048 Find Coins (25 分)

来源:互联网 收集:自由互联 发布时间:2021-06-10
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 1 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤, the total number of coins) and M (≤, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V?1?? and V?2?? (separated by a space) such that V?1??+V?2??=M and V?1??V?2??. If such a solution is not unique, output the one with the smallest V?1??. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

 

#include <iostream>
#include <vector>
#define E 1000
using namespace std;
int main(){
    int N,M,tmp;
    cin>>N>>M;
    int val[E]={0};
    while(N--){
        scanf("%d",&tmp);
        val[tmp]++;
    }
    bool flag=true;
    for(int i=0;i<E;i++){
        if(val[i]!=0&&val[M-i]!=0&&(M-i)>=0) {
            if(i!=(M-i)||(i==(M-i)&&val[i]>1)){
                cout<<i<<" "<<(M-i);
                flag=false;
                break;
            }
        }
    }
    if(flag) cout<<"No Solution";
    system("pause");
    return 0;
}
上一篇:Manacher
下一篇:select
网友评论