当前位置 : 主页 > 手机开发 > ROM >

Just an Old Puzzle(2019多校1007)

来源:互联网 收集:自由互联 发布时间:2021-06-10
Problem Description You are given a 4 × 4 grid, which consists of 15 number cells and an empty cell. All numbers are unique and ranged from 1 to 15. In this board, the cells which are adjacent with the empty cell can move to the empty cell
Problem Description You are given a 4 × 4 grid, which consists of 15 number cells and an empty cell.
All numbers are unique and ranged from 1 to 15.
In this board, the cells which are adjacent with the empty cell can move to the empty cell.
Your task is to make the input grid to the target grid shown in the figure below.
In the following example (sample input), you can get the target grid in two moves.
分享图片
 

 

Input The first line contains an integer T (1 <= T <= 10^5) denoting the number of test cases.
Each test case consists of four lines each containing four space-separated integers, denoting the input grid. 0 indicates the empty cell.  

 

Output For each test case, you have to print the answer in one line.
If you can’t get the target grid within 120 moves, then print ‘No‘, else print ‘Yes‘.  

 

Sample Input 2 1 2 3 4 5 6 7 8 9 10 0 12 13 14 11 15 1 2 3 4 5 6 7 8 9 10 11 12 13 15 14 0  

 

Sample Output Yes No

 结论:拼图可解问题:当前空白的行距的奇偶性与当前序列的逆序数的奇偶性的抑或值来判断

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
#include<cmath>

const int maxn=1e5+5;
typedef long long ll;
using namespace std;
int a[25];
int cc[25];
int main()
{
    int T;
    cin>>T;
    int k=0;

    while(T--)
    {
        int cnt=0;
        for(int t=0;t<4;t++)
        {
            for(int j=0;j<4;j++)
            {
                scanf("%d",&a[t*4+j]);
                if(a[t*4+j]!=0)
                {
                    cc[cnt++]=a[t*4+j];
                }
                if(a[t*4+j]==0)
                {
                    k=t;
                }
            }
        }
    int sum=0;
    for(int t=0;t<15;t++)
    {
        for(int j=t+1;j<15;j++)
        {
            if(cc[j]<cc[t])
            {
                sum++;
            }
        }
    }
    
    if(((3-k)%2)^(sum%2)==0)
    {
        puts("Yes");
    }
    else
    {
        puts("No");
    }    
    }
    return 0;
}
网友评论