ACboy needs your help again!
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5937 Accepted Submission(s): 3105
Problem Description
ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT
Sample Output
1
2
2
1
1
2
None
2
3
Source
2007省赛集训队练习赛(1)
Recommend
lcy | We have carefully selected several similar problems for you: 1700 1703 1704 1706 1705
题解:模拟栈和队列....STL
AC代码:
#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
#include<queue>
#include<stack>
using namespace std;
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int N,tmp;
scanf("%d",&N);
char str[10];
scanf("%s",str);
if(!strcmp(str,"FIFO"))
{
queue<int> q;
for(int i=0;i<N;i++)
{
scanf("%s",str);
if(!strcmp(str,"IN"))
{
scanf("%d",&tmp);
q.push(tmp);
}
else if(!strcmp(str,"OUT"))
{
if(q.empty())
{
printf("None\n");
}
else
{
printf("%d\n",q.front());
q.pop();
}
}
}
}
else if(!strcmp(str,"FILO"))
{
stack<int> s;
for(int i=0;i<N;i++)
{
scanf("%s",str);
if(!strcmp(str,"IN"))
{
scanf("%d",&tmp);
s.push(tmp);
}
else if(!strcmp(str,"OUT"))
{
if(s.empty())
{
printf("None\n");
}
else
{
printf("%d\n",s.top());
s.pop();
}
}
}
}
}
return 0;
}