当前位置 : 主页 > 编程语言 > java >

Network Saboteur

来源:互联网 收集:自由互联 发布时间:2022-08-15
Problem Description A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.



Problem Description


A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).


Input


The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). <br>Output file must contain a single integer -- the maximum traffic between the subnetworks. <br>


Output


Output must contain a single integer -- the maximum traffic between the subnetworks.


Sample Input



3
0 50 30
50 0 40
30 40 0


Sample Output


90



很多点直接有距离,把这些点分成两和集合,就两个集合最大的分法。


思路:


用dfs()不断循环把点分到两个集合。


代码:


#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int n;
int map[22][22];
int po[22];
int sum=0;
int sun;
int dfs(int k)
{
if(k==n+1)
{
if(sum<sun)sum=sun;
return 0;

}


int an=0;
for(int j=1;j<=k-1;j++)
{
if(po[j]){
an+=map[k][j];

}
}
sun+=an;
dfs(k+1);
sun-=an;
po[k]=1;
an=0;
for(int j=1;j<=k-1;j++)
{
if(!po[j]){
an+=map[k][j];

}
}
sun+=an;
dfs(k+1);
sun-=an;
po[k]=0;



}

int main()
{
while(cin>>n)
{ memset(map,0,sizeof(map));
memset(po,0,sizeof(po));
sum=0;
sun=0;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
scanf("%d",&map[i][j]);
}
}

po[1]=1;
dfs(1);
printf("%d\n",sum);
}


return 0;
}







上一篇:动态规划--最长上升子序列
下一篇:没有了
网友评论