当前位置 : 主页 > 编程语言 > java >

PAT甲级1024

来源:互联网 收集:自由互联 发布时间:2022-09-02
1024. Palindromic Number (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A number that will be the same when it is written forwards or backwards is known as a Palindromic Numb


1024. Palindromic Number (25)


时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue


A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.


Sample Input 1:


67 3


Sample Output 1:


484 2


Sample Input 2:


69 3


Sample Output 2:


1353 3




#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
bool checkPalindromic(deque<char>dq)
{
int i = 0, j = dq.size() - 1;
while (i <= j)
{
if (dq[i] != dq[j])
return false;
i++; j--;
}
return true;
}
int main()
{
char N[20];
int K;
scanf("%s %d", N, &K);
int len = strlen(N);
deque<char> dq,dq1,dq2;
for (int i = 0; i < len; i++)
{
dq.push_back(N[i]);
}
dq1 = dq2 = dq;
reverse(dq2.begin(), dq2.end());
int i = 1;
int t, carry = 0;
if (checkPalindromic(dq))
{
for (int i = 0; i < dq.size(); i++)
{
printf("%c", dq[dq.size() - 1 - i]);
}
printf("\n%d", 0);
return 0;
}//若本身就是回文数,则不需进行计算了
while (i <=K)
{
for (int j = 0; j < dq.size(); j++)
{
t = dq1[j] - '0' + dq2[j] - '0' + carry;
carry = 0;
if (t >= 10)
{
dq[j] = '0' + t - 10;
carry = 1;
}
else
dq[j] = '0' + t;
}
if (carry)
{
dq.push_back('1');
carry = 0;
}
if (checkPalindromic(dq))
{
break;
}
else
{
dq1 = dq2 = dq;
reverse(dq2.begin(), dq2.end());
i++;
}
}
if (i > K)
{
for (int i = 0; i < dq.size(); i++)
{
printf("%c", dq[dq.size() - 1 - i]);
}
printf("\n%d",K);
}
else
{
for (int i = 0; i < dq.size(); i++)
{
printf("%c", dq[dq.size() - 1 - i]);
}
printf("\n%d", i);
}
return 0;
}


上一篇:PAT甲级1070
下一篇:没有了
网友评论