本质就是逆序对的问题;
考虑动态规划求解:
考虑 dp[ i ] [ j ].
表示 i 个数排列 逆序对个数为 j 时 的方案数;
转移方程: dp[ i ][ j ]= dp[ i-1 ][ j ]*(j+1) + dp[ i-1 ][ j-1 ]*(i-j)。
初始化时 dp[ i ][ 0 ]=1;
Given a positiveinteger, N, a permutation oforder N is a one-to-one (and thus onto)function from the set of integers from 1to N to itself. If p is such a function, we representthe function by a list of its values:
[ p(1) p(2) … p(N)]
For example,
[5 6 2 4 7 1 3] represents the function from { 1 … 7 } to itself which takes 1to 5, 2 to 6, … , 7 to 3.
Forany permutation p, a descent of p isan integer k for which p(k) > p(k+1).For example, the permutation [5 6 24 7 1 3] has a descent at 2 (6 > 2) and 5 (7 > 1).
Forpermutation p, des(p) is the number of descents in p. For example, des([5 6 2 4 7 1 3]) = 2. The
identity permutation isthe only permutation with des(p) = 0. The reversing permutation with
p(k) = N+1-k is the only permutation with des(p) = N-1.
The permutation descent count (PDC)for given order N and value v is the number of permutations p
of order N withdes(p)= v.For example:
PDC(3, 0) = 1 { [ 1 2 3 ] }
PDC(3, 1) = 4 { [ 1 3 2 ], [ 2 1 3 ], [ 2 3 1 ], 3 1 2 ] }
PDC(3, 2) = 1 { [ 3 2 1 ] }
Write a program to compute the PDCfor inputs N and v. To avoid having to deal with verylarge numbers, your answer (and your intermediate calculations) will becomputed modulo 1001113.
Input
The first lineof input contains a single integer P, (1 £ P £ 1000), which is thenumber of data sets that follow. Each data set should be processed identicallyand independently.
Each data set consists of a single line of input. It contains thedata set number, K, followed by the integer order, N (2 £ N £ 100), followed by aninteger value, v (0 £ v £ N-1).
Output
For each dataset there is a single line of output. The single output line consists of thedata set number, K, followed by a single space followed by the PDC of N and v modulo 1001113 as a decimal integer.
Sample Input
Sample Output
4
1 3 1
2 5 2
3 8 3
4 99 50
1 4
2 66
3 15619
4 325091
#include<iostream>#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<set>
#include<map>
using namespace std;
typedef long long ll;
#define maxn 2005
#define inf 0x3f3f3f3f
#define ii 0x3f
const int mod = 1001113;
ll read() {
ll x = 0, f = 1;
char ch = getchar();
while (ch < '0' || ch > '9') {
if (ch == '-') {
f = -1;
}
ch = getchar();
}
while (ch >= '0'&&ch <= '9') {
x = x * 10 + ch - '0';
ch = getchar();
}
return x * f;
}
ll quickpow(ll a, ll b) {
ll ans = 1;
while (b > 0) {
if (b % 2)ans = ans * a;
b = b / 2;
a = a * a;
}
return ans;
}
//char s[maxn];
int gcd(int a, int b) {
return b == 0 ? a : gcd(b, a%b);
}
int p, k, n, v;
int dp[maxn][maxn];
void js() {
memset(dp, 0, sizeof(dp));
dp[2][1] = 1;
dp[2][0] = 1;
for (int i = 3; i <= 100; i++) {
dp[i][0] = 1;
for (int j = 1; j < i - 1; j++) {
dp[i][j] = (dp[i - 1][j] * (j + 1) + dp[i - 1][j - 1] * (i - j)) % mod;
}
dp[i][i - 1] = 1;
}
}
int main() {
ios::sync_with_stdio(false);
js();
cin >> p;
while (p--) {
cin >> k >> n >> v;
cout << k << ' ' << dp[n][v] << endl;
}
}