http://www.elijahqi.win/archives/399
Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20083 Accepted: 10436
Description
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:
Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).
Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5
Source
POJ Monthly–2006.01.22,Zeyuan Zhu
求前缀等于后缀的串的长度,那么当然有自己咯
我这个比较懒,用了 priority_queue就慢了,其实直接递归打印就可以了
#include<cstring>
#include<queue>
#define N 4400000
using namespace std;
priority_queue<int,vector<int>,greater<int> > q;
int next[N];char a[N];
int main(){
freopen("poj2752.in","r",stdin);
//freopen("poj2752.out","w",stdout);
while (~scanf("%s",a)){
int n=strlen(a);
int i=0,j=-1;next[0]=-1;
while (i<n) {
if (j==-1||a[i]==a[j]){
++i;++j;next[i]=j;
}else j=next[j];
}
// for (int i=1;i<=n;++i) printf("%d,next[i]);printf("asdfa\n");
for (int j=next[n];j;j=next[j])q.push(j);//printf("1 ");
while (!q.empty()) printf("%d,q.top()),q.pop();printf("%d,n);
//if ((next[n]<<1)==n) printf("%d")
printf("\n");
}
return 0;
}