Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 146218 Accepted Submission(s): 35530
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 2 10
0 0 0
Sample Output
2
5
Author
CHEN, Shunbao
Source
ZJCPC2004
Recommend
JGShining | We have carefully selected several similar problems for you: 1008 1021 1019 1009 1012
我试了一下用递归来解决这问题,看看会不会TLE。。。。结果真的TLE。。。
TLE代码:
#include<iostream>
#include<cstdio>
using namespace std;
int ans;int A,B;
int f(int n){
if(n==1||n==2)return 1;
if(n>=3)
return (A*f(n-1)+B*f(n-2))%7;
}
int main()
{
int n;
while(~scanf("%d%d%d",&A,&B,&n))
{
if(A==0&&B==0&&n==0)break;
ans=f(n);
printf("%d\n",ans);
}
return 0;
}
改为DP后AC,注意结果每48个为一个周期。(这个坑爹。。。)
AC代码:
#include<iostream>
#include<cstdio>
int main()
{
int a,b,n;
while(~scanf("%d%d%d",&a,&b,&n)){
if(a==0&&b==0&&n==0)break;
int arr[48];
arr[1]=1;
arr[2]=1;
for(int i=3;i<48;i++)
arr[i]=((a*arr[i-1]+b*arr[i-2])%7);
printf("%d\n",arr[n%48]);
}
}