当前位置 : 主页 > 编程语言 > java >

HDU 1862 EXCEL排序(结构体排序)

来源:互联网 收集:自由互联 发布时间:2022-08-15
EXCEL排序 Time Limit: 10000/5000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 16387Accepted Submission(s): 6137 Problem Description Excel可以对一组纪录按任意指定列排序。现请你编写程序


EXCEL排序


Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16387    Accepted Submission(s): 6137


Problem Description

Excel可以对一组纪录按任意指定列排序。现请你编写程序实现类似功能。


Input

测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有 N
行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。


Output

对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。


Sample Input


3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
0 0


Sample Output

Case 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Case 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Case 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90



Source

​​浙大计算机研究生复试上机考试-2007年 ​​


题解:结构体排序,注意c=1,c=2,c=3时的分类条件


AC代码:


#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;
struct stud
{
int num;
char name[10];
int score;
} stu[100001];
int cmp1(stud a,stud b)
{
return a.num<b.num;
}
int cmp2(stud a,stud b)
{
if(strcmp(a.name,b.name)==0)
return a.num<b.num;
return strcmp(a.name,b.name)<0;
}
int cmp3(stud a,stud b)
{
if(a.score==b.score)
return a.num<b.num;
return a.score<b.score;
}
int main()
{
int n,c,cas=1;
while((cin>>n>>c)&&(n||c))
{
memset(stu,0,sizeof(stu));
for(int i=0; i<n; i++)
scanf("%d %s %d",&stu[i].num,stu[i].name,&stu[i].score);
if(c==1)
sort(stu,stu+n,cmp1);
else if(c==2)
sort(stu,stu+n,cmp2);
else if(c==3)
sort(stu,stu+n,cmp3);
printf("Case %d:\n",cas++);
for(int i=0; i<n; i++)
printf("%06d %s %d\n",stu[i].num,stu[i].name,stu[i].score);
}
return 0;
}




 

【文章原创作者:华为云代理 http://www.558idc.com/hw.html处的文章,转载请说明出处】
上一篇:HDU 1279 验证角谷猜想(数学)
下一篇:没有了
网友评论