当前位置 : 主页 > 手机开发 > harmonyos >

杭电ACM HDU 3351 Seinfeld

来源:互联网 收集:自由互联 发布时间:2023-08-26
Seinfeld Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1071 Accepted Submission(s): 540 Problem Description I’m out of stories. For years I’ve been writing stories, some rather sil


Seinfeld

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1071    Accepted Submission(s): 540


Problem Description


I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.



 


Input


Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)



 


Output


For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.



 


Sample Input


}{ {}{}{} {{{} ---



 


Sample Output


1. 2 2. 0 3. 1



 


Source


2009 ANARC



 


Recommend


lcy



 

再贴一道水题

#include<cstdio>
int main(){
    char str[2013];
    int i,c=1,a,b;
    while(gets(str)&&str[0]!='-'){
        for(i=a=b=0;str[i];i++)
            if(str[i]=='{') a++;
            else a?a--:b++;
        printf("%d. %d\n",c++,(a+1)/2+(b+1)/2);
    }
}

 

上一篇:编译原理 语法分析器
下一篇:没有了
网友评论