数据结构实验之链表三:链表的逆置 Time Limit:1000 msMemory Limit:65536 KiB SubmitStatistic Problem Description 输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的
数据结构实验之链表三:链表的逆置
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description
输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。
Input
输入多个整数,以-1作为结束标志。
Output
输出逆置后的单链表数据。
Sample Input
12 56 4 6 55 15 33 62 -1
Sample Output
62 33 15 55 6 4 56 12
Hint
不得使用数组。
Source
#include <stdio.h>
#include <stdlib.h>
struct node
{
int data;
struct node *next;
};
int main()
{
struct node *head, *p, *tail;
head = (struct node *)malloc(sizeof(struct node));
head->next = NULL;
tail = head;
int x;
while(scanf("%d", &x) != EOF)
{
if(x == -1)
{
break;
}
else
{
p = (struct node *)malloc(sizeof(struct node));
p->data = x;
p->next = head->next;
head->next = p;
}
}
p = head->next;
while(p != NULL)
{
printf("%d ", p->data);
p = p->next;
}
return 0;
}