当前位置 : 主页 > 编程语言 > c语言 >

数据结构实验之链表二:逆序建立链表

来源:互联网 收集:自由互联 发布时间:2023-09-03
数据结构实验之链表二:逆序建立链表 Time Limit:1000 msMemory Limit:65536 KiB SubmitStatistic Problem Description 输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍


数据结构实验之链表二:逆序建立链表

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

Input

第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。

Output

依次输出单链表所存放的数据。

Sample Input


10 11 3 5 27 9 12 43 16 84 22


Sample Output


22 84 16 43 12 9 27 5 3 11


Hint

不能使用数组!

Source

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
int main()
{
    struct node *head, *p, *tail;
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    tail = head;
    int n, i;
    scanf("%d", &n);
    for(i = 1; i <= n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p->data);
        p->next = head->next;
        head->next = p;
    }
    p = head->next;
    while(p != NULL)
    {
        printf("%d ", p->data);
        p = p->next;
    }
    return 0;
}

 

上一篇:数据结构实验之图论二:图的深度遍历
下一篇:没有了
网友评论