当前位置 : 主页 > 编程语言 > c语言 >

POJ 1961 Period(KMP)

来源:互联网 收集:自由互联 发布时间:2023-09-07
Period Time Limit:3000MS Memory Limit:30000K Total Submissions:12709 Accepted:5939 Description For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether t


Period


Time Limit: 3000MS

 

Memory Limit: 30000K

Total Submissions: 12709

 

Accepted: 5939


Description


For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.


Input


The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.


Output


For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.


Sample Input


3 aaa 12 aabaabaabaab 0


Sample Output


Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4


#include<stdio.h>
#include<string.h>
char a[1000010];
int next[1000010];
int main()
{
    int n,m;
    int k = 0;
    while(scanf("%d",&m)!=EOF && m!=0)
    {
        scanf("%s",a);
        k++;
        n = strlen(a);
        int i = 0;
        int j = -1;
        next[i] = -1;
        while(i<n)
        {

            if(j == -1 || a[j] == a[i])
            {
                 i++;
                 j++;
              next[i] = j;
            }
            else
            {
                j = next[j];
            }

        }
        printf("Test case #%d\n",k);
          for( i=2;i<=n;i++)
            {
                if(i%(i-next[i])==0)
                {
                    if(i/(i-next[i])>1)
                printf("%d %d\n",i,i/(i-next[i]));
                }
          }
          printf("\n");
    }
    return 0;
}


上一篇:A. Feed with Candy
下一篇:没有了
网友评论