当前位置 : 主页 > 手机开发 > harmonyos >

杭电ACM HDU 1084 What Is Your Grade?

来源:互联网 收集:自由互联 发布时间:2023-08-26
What Is Your Grade? Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6735 Accepted Submission(s): 2052 Problem Description “Point, point, life of student!” This is a ballad(歌谣)


What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6735    Accepted Submission(s): 2052


Problem Description


“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!



 


Input


Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.



 


Output


Output the scores of N students in N lines for each case, and there is a blank line after each case.



 


Sample Input


4 5 06:30:17 4 07:31:27 4 08:12:12 4 05:23:13 1 5 06:30:17 -1



 


Sample Output


100 90 90 95 100



 


Author


lcy



 

 

#include<stdio.h>
#include<stdlib.h>
typedef struct S{
    int p;//正确解题数
    int t;//用掉的时间
    int g;//分数
    int n;//输入的原始编号
}S;
S s[110];
int cmp(const void *a,const void *b){
    if((*(S*)a).p==(*(S*)b).p)
        return (*(S*)a).t-(*(S*)b).t;
    return (*(S*)b).p-(*(S*)a).p;
}
int cmp2(const void *a,const void *b){
    return (*(S*)a).n-(*(S*)b).n;
}
int main(){
    int n,i;
    int sum[6],tol[6];
    int a,b,c,d;
    while(scanf("%d",&n)&&(n>0)){
        for(i=0;i<6;i++)tol[i]=sum[i]=0;
        for(i=0;i<n;i++){
            scanf("%d%d:%d:%d",&a,&b,&c,&d);
            s[i].p=a;
            s[i].n=i;
            s[i].t=b*3600+c*60+d;
            sum[a]++;
        }
        for(i=4;i>0;i--)
            tol[i]=tol[i+1]+sum[i+1];
        qsort(s,n,sizeof(s[0]),cmp);
        for(i=0;i<n;i++){
            s[i].g=s[i].p*10+50;
            if(s[i].p==0||s[i].p==5)continue;
            if(i-tol[s[i].p]<sum[s[i].p]/2)
                s[i].g+=5;
        }
        qsort(s,n,sizeof(s[0]),cmp2);
        for(i=0;i<n;i++)
            printf("%d\n",s[i].g);
        printf("\n");
    }
    return 0;
}

 

上一篇:北大ACM POJ 2602 Superlong sums
下一篇:没有了
网友评论