Dylans loves sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 55 Accepted Submission(s): 31
Problem Description
Dylans is given N numbers a[1]....a[N]
And there are Q questions.
Each question is like this (L,R)
his goal is to find the “inversions” from number L to number R.
more formally,his needs to find the numbers of pair(x,y),
that L≤x,y≤R and x<y and a[x]>a[y]
Input
In the first line there is two numbers N and Q.
Then in the second line there are N numbers:a[1]..a[N]
In the next Q lines,there are two numbers L,R in each line.
N≤1000,Q≤100000,L≤R,1≤a[i]≤231−1
Output
For each query,print the numbers of "inversions”
Sample Input
3 2
3 2 1
1 2
1 3
Sample Output
1
3
//由于N只有1000,所以先打表。。。感觉自己好笨 打表想了好久 。。唉
#include <stdio.h>
#include <algorithm>
using namespace std;
int c[1010][1010]={{0}};
int arr[1010]={9999999};
int main()
{
int n,m;
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
scanf("%d",&arr[i]);
int a,b;
for(int i=999;i>=0;i--) //计算每个i-k 有多少组
{
int cnt=0;
for(int k=i+1;k<=1000;k++)
{
if(arr[i]>arr[k])
cnt++;
c[i][k]=c[i+1][k]+cnt; //c[i][k]=c[i+1][k]+cnt[k]
}
}
while(m--)
{
scanf("%d%d",&a,&b);
printf("%d\n",c[a][b]);
}
return 0;
}