当前位置 : 主页 > 编程语言 > c语言 >

UVA (POJ 2109) Power of Cryptography

来源:互联网 收集:自由互联 发布时间:2023-09-07
Power of Cryptography Description Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number


Power of Cryptography



Description



Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
This problem involves the efficient computation of integer roots of numbers. 
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the n th. power, for an integer k (this integer is what your program must find).


Input



The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10 101 and there exists an integer k, 1<=k<=10 9 such that k n = p.


Output



For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.


Sample Input


2 163 277 4357186184021382204544


Sample Output


431234


Source



México and Central America 2004






#include<stdio.h>
#include<math.h>
#define  N 1000000
int main()
{
    double n,m;
    double t;
    int i;
    while(scanf("%lf%lf",&m,&n)!=EOF)
    {
        for(i=1;i<N;i++)
       {
           t = pow(i,m);
       if(t==n)
       {
           break;
       }
       }
        printf("%d\n",i);
    }
    return 0;
}









2







#include<stdio.h>
#include<math.h>
int main()
{
    double p,n;
    while(scanf("%lf%lf",&n,&p)!=EOF)
    {
        printf("%.lf\n",pow(p,1/n));
    }
}









Time Limit: 1000MS

 

Memory Limit: 30000K

Total Submissions: 18102

 

Accepted: 9135






【文章原创作者:美国服务器 http://www.558idc.com/mg.html提供,感恩】
上一篇:POJ 3278 Catch That Cow
下一篇:没有了
网友评论