当前位置 : 主页 > 编程语言 > c语言 >

POJ 1789 Truck History

来源:互联网 收集:自由互联 发布时间:2023-09-07
Truck History Time Limit:2000MSMemory Limit:65536KB64bit IO Format:%I64d %I64u Submit Status Practice POJ 1789 Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for


Truck History


Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u


Submit  Status  Practice  POJ 1789


Description



Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)
where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 



Input



The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.



Output



For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.



Sample Input



4 aaaaaaa baaaaaa abaaaaa aabaaaa 0



Sample Output



The highest possible quality is 1/3.







#include<stdio.h>
#include<string.h>
#define MAX 9999999
char a[10000][10000];
int map[11000][11000],p[10000];
int num[11000];
int n;
void dijkstra()
{
    int s = 1,i,j;
    memset(p,0,sizeof(p));
    memset(num,MAX,sizeof(num));
    for(i=1;i<=n;i++)
    {
        num[i] = map[s][i];
    }
    p[s] = 1;
    int sum = 0;
    for(i=1;i<n;i++)
    {
        int k,min = MAX;
        for(j=1;j<=n;j++)
        {
            if(p[j]==0 && min>num[j])
            {
                min = num[j];
                k = j;
            }
        }
            if(min == MAX)
            {
                break;
            }
            p[k] = 1;
            sum = sum + min;
            for(j=1;j<=n;j++)
            {
                if(p[j] == 0 && num[j]>map[k][j])
                {
                    num[j] = map[k][j];
                }
            }
    }
    printf("The highest possible quality is 1/%d.\n",sum);
}
int main()
{
    int m,i,j,k;
    while(scanf("%d",&n)!=EOF)
    {
        if(n == 0)
        {
            break;
        }
        for(i=1;i<=n;i++)
        {
            scanf("%s",&a[i]);
        }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                int count = 0;
                for(k=0;k<7;k++)
                {
                    if(a[i][k]!=a[j][k])
                    {
                        count++;
                    }
                }
                map[i][j] = count;
            }
        }
       /* for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                printf("%d ",map[i][j]);
            }
            printf("\n");
        }*/
        dijkstra();
    }
    return 0;
}




【转自:美国cn2服务器 http://www.558idc.com/mg.html欢迎留下您的宝贵建议】
上一篇:POJ 2251 Dungeon Master(三维BFS)
下一篇:没有了
网友评论