当前位置 : 主页 > 手机开发 > harmonyos >

HDU 5437

来源:互联网 收集:自由互联 发布时间:2023-08-28
Alisha’s Party Time Limit: 3000/2000 MS (Java/Others)Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 2342Accepted Submission(s): 638 Problem Description v, and all of them will come at a different time. Because the lobby


Alisha’s Party



                                                            Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)



                                                                         Total Submission(s): 2342    Accepted Submission(s): 638




Problem Description



v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let  p people enter her castle. If there are less than  p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query  n Please tell Alisha who the  n−th



 



Input



T , where  1≤T≤15.

In each test case, the first line contains three numbers  k,m and  q separated by blanks.  k is the number of her friends invited where  1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where  0≤m≤k. Alisha will have  q queries where  1≤q≤100.

The  i−th of the following  k lines gives a string  Bi, which consists of no more than  200 English characters, and an integer  vi,  1≤vi≤108, separated by a blank.  Bi is the name of the  i−th person coming to Alisha’s party and Bi brings a gift of value  vi.

Each of the following  m lines contains two integers  t(1≤t≤k) and  p(0≤p≤k) separated by a blank. The door will open right after the  t−th person arrives, and Alisha will let  p friends enter her castle.

The last line of each test case will contain  q numbers  n1,...,nq separated by a space, which means Alisha wants to know who are the  n1−th,...,nq−th friends to enter her castle.

Note: there will be at most two test cases containing  n>10000.



 



Output



For each test case, output the corresponding name of Alisha’s query, separated by a space.



 



Sample Input



1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3



 



Sample Output



Sorey Lailah Rose



 




#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <algorithm>
#include <map>
#include <queue>
using namespace std;
const int maxn=150000+10;
const int inf=(1<<30);

struct Node
{
    char s[300];
    int val;
    int i;
    friend bool operator < (const Node &a,const Node &b)
    {
        if(a.val==b.val)
            return a.i>b.i;
        return a.val<b.val;
    }
}p[maxn];

struct node
{
    int tol,conum;
}q[maxn];
bool cmp(node a,node b)
{
    return a.tol<b.tol;
}
int ans[maxn];
int main()
{
    int k,m,n,t;
    scanf("%d",&t);
    while(t--)
    {
        memset(ans,0,sizeof(ans));
        scanf("%d%d%d",&k,&m,&n);
        for(int i=0;i<k;i++)
        {
            scanf("%s%d",p[i].s,&p[i].val);
            p[i].i=i;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&q[i].tol,&q[i].conum);
        }
        sort(q,q+m,cmp);
        priority_queue <Node> qu;
        int cnt,cnt1;
        cnt=0,cnt1=1;
        for(int i=0;i<k;i++)
        {
            qu.push(p[i]);
            if(cnt<m&&i==q[cnt].tol-1)
            {
                while(q[cnt].conum--&&!qu.empty())
                {
                    ans[cnt1++]=qu.top().i;
                    qu.pop();
                }
                cnt++;
            }
        }
        while(!qu.empty())
        {
            ans[cnt1++]=qu.top().i;
            qu.pop();
        }
        while(n--)
        {
            int res;
            scanf("%d",&res);
            if(n==0)
                printf("%s\n",p[ans[res]].s);
            else
                printf("%s ",p[ans[res]].s);
        }
    }
    return 0;
}




上一篇:cf 599 A (模拟)
下一篇:没有了
网友评论