当前位置 : 主页 > 编程语言 > c语言 >

POJ 2485 Highways(最短路)

来源:互联网 收集:自由互联 发布时间:2023-09-07
Highways Time Limit:1000MSMemory Limit:65536KB64bit IO Format:%I64d %I64u Submit Status Practice POJ 2485 System Crawler (2014-09-09) Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highway


Highways


Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u


Submit  Status  Practice  POJ 2485


System Crawler  (2014-09-09)



Description



The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.



Input



The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.



Output



For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.



Sample Input



1 3 0 990 692 990 0 179 692 179 0



Sample Output



692



Hint



Huge input,scanf is recommended.











#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define N 1005
#define INF 0x7fffffff

int map[N][N],v[N];
int num[N];
int n;

void prime()
{
    int s = 0;
    int i,j;
    int max = 0;
    memset(v,0,sizeof(v));
    for(i=0;i<=n;i++)
    {
        num[i] = INF;
    }
    for(i=0;i<n;i++)
    {
        num[i] = map[s][i];
    }
    num[s] = 0;
    for(i=0;i<n;i++)
    {
        int min = INF,k;
        for(j=0;j<n;j++)
        {
            if(v[j] == 0 && num[j]<min)
            {
                min = num[j];
                k = j;
            }
        }
        if(min == INF)
        {
            break;
        }
        if(max<min)
        {
            max = min;
        }
        v[k] = 1;
        for(j=0;j<n;j++)
        {
            if(v[j] == 0 && num[j]>map[j][k])
            {
                num[j] = map[j][k];
            }
        }
    }
    printf("%d\n",max);
}

int main()
{
    int i,j;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                scanf("%d",&map[i][j]);
            }
        }
        prime();
    }
    return 0;
}



上一篇:POJ 2502 Subway(最短路)
下一篇:没有了
网友评论