当前位置 : 主页 > 手机开发 > harmonyos >

HDU 1892(树状数组二维)

来源:互联网 收集:自由互联 发布时间:2023-08-28
See you~ Time Limit: 5000/3000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others) Total Submission(s): 4167 Accepted Submission(s): 1311 Problem Description Now I am leaving hust acm. In the past two and half years, I learned so man


See you~

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4167    Accepted Submission(s): 1311

Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year. 
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles. 
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position. 
 
Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed. 
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries. 
There are 4 kind of queries, sum, add, delete and move. 
For example: 
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points. 
A x1 y1 n1 means I put n1 books on the position (x1,y1) 
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them. 
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them. 
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100. 
 
Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries. 
For each "S" query, just print out the total number of books in that area. 
 
Sample Input
2
3
S 1 1 1 1
A 1 1 2
S 1 1 1 1
3
S 1 1 1 1
A 1 1 2
S 1 1 1 2
 
Sample Output
Case 1:
1
3
Case 2:
1
4

//注意数据是从0开始 树状数组是从1开始


#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
const int N=1010;
int c[N][N];
int a[N][N];  //记录当前a[i][j]目前的书
int n=N;
int lowbit(int x)
{
    return x&(-x);
}

void add(int x,int y,int val)
{
    int i=y;
    while(x<=n)
    {
        y=i;
        while(y<=n)
        {
            c[x][y]+=val;
            y+=lowbit(y);
        }
        x+=lowbit(x);
    }
}

int sum(int x,int y)
{
    int i,sum=0;
    i=y;
    while(x)
    {
        y=i;
        while(y)
        {
            sum+=c[x][y];
            y-=lowbit(y);
        }
        x-=lowbit(x);
    }
    return sum;
}

int main()
{
    int t,cnt=1;
    scanf("%d",&t);
    while(t--)
    {
        int n,x1,y1,x2,y2,n1;
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        for(int i=1;i<=N;i++)
        {
            for(int k=1;k<=N;k++)  //一开始为1
            {
                add(i,k,1);
                a[i][k]=1;
            }
        }
        printf("Case %d:\n",cnt++);
        scanf("%d",&n);
        char ch;
        while(n--)
        {
            getchar();
            scanf("%c",&ch);
            if(ch=='S')
            {
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);  //这里的x y需要判断 其实感觉二维的题都加一个判断更好
                x1++,y1++,x2++,y2++;
               if(x1>x2)
                    swap(x1,x2);
                if(y1>y2)
                    swap(y1,y2);
                printf("%d\n",sum(x2,y2)+sum(x1-1,y1-1)-sum(x2,y1-1)-sum(x1-1,y2));
            }
            else if(ch=='A')
            {
                 scanf("%d%d%d",&x1,&y1,&n1);
                 add(x1+1,y1+1,n1);
                 a[x1+1][y1+1]+=n1;
            }
            else if(ch=='D')
            {
                 scanf("%d%d%d",&x1,&y1,&n1);
                 if(n1>a[x1+1][y1+1])
                    n1=a[x1+1][y1+1];
                 add(x1+1,y1+1,-n1);
                 a[x1+1][y1+1]-=n1;
            }
            else if(ch=='M')
            {
                scanf("%d%d%d%d%d",&x1,&y1,&x2,&y2,&n1);
                if(a[x1+1][y1+1]<n1)
                {
                   n1=a[x1+1][y1+1];
                }
                add(x1+1,y1+1,-n1);
                add(x2+1,y2+1,n1);
                a[x1+1][y1+1]-=n1;
                a[x2+1][y2+1]+=n1;

            }

        }
    }
    return 0;
}




上一篇:HDU 5494(水题)
下一篇:没有了
网友评论