当前位置 : 主页 > 手机开发 > harmonyos >

HDU 2689

来源:互联网 收集:自由互联 发布时间:2023-08-28
Sort it Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3379 Accepted Submission(s): 2446 Problem Description You want to processe a sequence of n distinct integers by swapping two adjac


Sort it

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3379    Accepted Submission(s): 2446

Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
 
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
 
Output
For each case, output the minimum times need to sort it in ascending order on a single line.
 
Sample Input
3
1 2 3

4 3 2 1 
 
Sample Output
0

6

//这题求得是逆序数 冒泡也也行


#include <stdio.h>
#include <cstring>
int n,c[10010];
int lowbit(int x)
{
    return x&(-x);
}

void add(int i,int x)
{
    while(i<=n)
    {
        c[i]+=x;
        i+=lowbit(i);
    }
}

int sum(int i)
{
    int sum=0;
    while(i)
    {
        sum+=c[i];
        i-=lowbit(i);
    }
    return sum;
}

int main()
{
    while(~scanf("%d",&n))
    {
        int a,s=0;
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a);
            add(a,1);
            s+=i-sum(a);
        }
        printf("%d\n",s);
    }


    return 0;
}




上一篇:HDU 3342
下一篇:没有了
网友评论