Triangle LOVE
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3464 Accepted Submission(s): 1342
Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.
It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).
Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
Sample Input
2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110
Sample Output
Case #1: Yes
Case #2: No
//由题意可知 n=1 2不可能 出现 所以大于3的时候出现环就可以了
#include <stdio.h>
#include <string.h>
char s[2010][2010];
int ma[2010];
int main()
{
int t,cnt1=1;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
memset(ma,0,sizeof(ma));
for(int i=0;i<n;i++)
scanf("%s",s[i]);
for(int i=0;i<n;i++)
{
for(int k=0;k<n;k++)
{
if(s[i][k]=='1')
ma[k]++;
}
}
int flag=0;
for(int i=0;i<n;i++)
{
int k;
for(k=0;k<n;k++)
if(ma[k]==0)
break;
if(k==n) //入度都不为0
{
flag=1;
break;
}
else
{
ma[k]--;
for(int j=0;j<n;j++)
if(s[k][j]=='1')
ma[j]--;
}
}
if(flag)
printf("Case #%d: Yes\n",cnt1++);
else
printf("Case #%d: No\n",cnt1++);
}
return 0;
}